Hinweis Probleme mit JAG3D unter Java 11

by Micha ⌂ @, Saturday, January 19, 2019, 09:42 (217 days ago) @ Heinz-Theo

Hallo Theo,

erst einmal noch die besten Wünsche für 2019.

Danke, Dir auch ein erfolgreiches neues Jahr.

Sie liegt überall unter "C:\Program Files\Java\jdk-11.0.2\bin\".

Dann müsstest Du es über die shell starten können. In der Annahme, dass Du Dich bereits im JAG3D-Verzeichnis befindest, ist der Aufruf:

"C:\Program Files\Java\jdk-11.0.2\java" -jar jag3d.jar

Wenn man Jag3d starten will (egal ob die jar oder die exe) kommt als Fehlermeldung, dass die Runtime 9.0.0 erforderlich ist

Das dürfte nicht passieren, wenn Du die jar direkt startest. Die Fehlermeldung kommt von der exe, die ich mit Launch4j erstellt habe. Startest Du diese exe, wird geprüft, ob Du die notwendige Java-Version auf Deinem Rechner hast. Wenn dies nicht der Fall ist, bekommst Du den genannten Hinweis. Zu diesem Zeitpunkt ist JAG3D noch nicht im Spiel.

Wenn Du die jar direkt startest, dann findet keine direkte Prüfung statt. JAG3D startet nicht, wenn es ein Versionskonflikt feststellt (und würde auf der Shell einen Fehler liefern)

Ich habe mal eine Version erstellt, die ohne installiertes Java auskommt und die JRE direkt mit enthält - praktisch eine Standalone Version. Ich habe das OpenJDK 11 genommen. Die könntest Du alternativ mal ausprobieren. Auch hierfür könnte man eine exe mit Launch4j erzeugen. Hier der Link zur portablen Version von JAG3D:

https://dev.applied-geodesy.org/tmp/JAG3Dv20190109_OpenJDK_Windows.zip

Viele Grüße
Micha

--
applied-geodesy.org - OpenSource Least-Squares Adjustment Software for Geodetic Sciences

Tags:
JAG3D, java 11, portable app, windows


Complete thread:

 RSS Feed of thread