LANDxml-Importproblem und Problem-Ergebnis Datumsanschluss

by N_Haas, Tuesday, July 30, 2019, 09:15 (21 days ago)

Hallo erstmal hier im Forum

Es geht um folgende Idee:

Da die Registrierung von Punktwolken mit der "FARO-Scene" Software mehr oder minder eine "Black-Box"-Lösung ist, es aber die Möglichkeit gibt, die "Messwerte" der einzelnen Scanner-Standpunkte zu den Referenz- und Verknüpfungspunkten auszulesen, soll in JAG3D damit eine freie Netzausgleichung gerechnet und die sich daraus ergebenden verbesserten Registrierungsdaten der Scanstandpunkte zurück in die Punktwolken-Software gelesen werden.

Die Scans sollen jedes Jahr wiederholt und die sich daraus ergebenden Projektpunktwolken mittels "CloudCompare" verglichen werden (-> Verformung, Schadensdokumentation usw.).

Die "wahre" Lage und eine ordentliche Berechnungsdokumentation sollte mittels JAG3D viel besser erreichbar sein. Aus "FARO-Scene" ausgelesen werden die sich aus dem Raumvektor Scanstandpunkt zu Verknüpfungs/Referenzpunkt ergebenden HZ-Winkel, V-Winkel und Schrägstrecke, außerdem die Koordinaten der Punkte aus der Vorregistrierung (-> Näherungswerte).
Das Ergebnis ist eine LANDxml-Datei der "Beobachtungen"
(Aus_FARO_Scene_Stadtmauer_BW2.074_Prüfmessung_20190729_120741_LandXML.xml),
eine Datei mit Referenzpunkten
(Aus_FARO_Scene_Stadtmauer_BW2.074_Prüfmessung_20190729_120741_RefernceCoordinates.rmk)
und eine Datei mit den Näherungskoordinaten der Neupunkte
(Aus_FARO_Scene_Stadtmauer_BW2.074_Prüfmessung_20190729_120741_ObjectCoordinates.rmk).

Die Referenzpunkte stammen aus einer tachymetrischen Netzmessung (jedes Jahr wieder als Epochenbeobachtung von ungefährdeten Festpunkten aus).
Die Referenzpunkte kann ich als Raumdatumspunkte, die Neupunkte als Raumneupunkte importieren, dann kommt das erste Problem. Irgendwie funktioniert der Import der LANDxml-Datei nicht (für HZ, V und Schrägstrecke), d.h. ich starte den Import über Import->Hexagon/Leica->LANDxml_1.2_3D und dann passiert nichts, keine Fehlermeldung und auch keinerlei Import. Die Infos im Dateiheader besagen aber, das es sich um die korrekte Version handelt (LANDxml-1.2), die gewünschten Messwerte sind enthalten. Was mache ich falsch?

Danach habe ich die Messwerte manuell aus der LANDxml-Datei in eine CSV-Datei extrahiert und die Messwerte damit eingelesen, was auch problemlos funktioniert. Dann wurde die Ausgleichung ausgeführt, was zu meinem zweiten Problem führt.
Die ausgeglichenen Koordinaten der Datums/Neupunkte weichen erheblich von den eingelesenen Anschluss/Näherungskoordinaten ab. Die Abweichungen sind viel größer als erwartet. Erwartet wurden mm-Verbesserungen nicht dm-Verbesserungen.

Zur Kontrolle habe ich im Vermessungsmodul der CARD_1 Tiefbausoftware mit den gleichen Messwerten (CARD_1 Beobachtungen.wsh) und Anschlusspunkten (CARD_1_Datumsanschlusspunkte.ASC) eine Netzausgleichung mit 3D-Datumsanschluss berechnet. Hier kommt es zu dem erwarteten Ergebnis (mm-Verbeserungen, siehe -> "CARD_1 Protokoll Netzberechnung.txt").
Wie kann das sein?... vielmehr, was mache ich falsch?

Um das Ganze etwas besser nachvollziehbar zu machen, habe ich alle relevanten Daten unter folgendem Link hochgeladen und stehen für 21 Tage zum Download bereit.

https://da.nuernberg.de/daservice/download?id=c78b87146cd645f380e466bee66d6b4d

(Ausgangsdaten und Ergebnisse der Ausgleichung für JAG3D, für CARD_1-Ausgleichung, sowie das JAG3D-Projekt)

Ein paar gute Ideen wären super!

Grüße aus Franken
Norbert Haas


Complete thread:

 RSS Feed of thread